Login | Register
My pages Projects Community openCollabNet

Discussions > issues > [Issue 21] New - <property file="whatever" /> produces spurious "Unable to find property file" messages

antelope
Discussion topic

Back to topic list

[Issue 21] New - &lt;property file="whatever" /&gt; produces spurious "Unable to find property file" messages

Author esafern
Full name Eric Safern
Date 2004-08-02 20:10:18 PDT
Message http://antelope.tigr​is.org/issues/show_b​ug.cgi?id=21
                  Issue #:|21
                  Summary:|<property file="whatever" /> produces spurious
                          |"Unable to find property file" messages
                Component:|antelope
                  Version:|current
                 Platform:|All
               OS/Version:|All
                      URL:|
                   Status:|NEW
        Status whiteboard:|
                 Keywords:|
               Resolution:|
               Issue type:|DEFECT
                 Priority:|P3
             Subcomponent:|www
              Assigned to:|issues@antelope
              Reported by:|esafern






------- Additional comments from esafern at tigris dot org Mon Aug 2 20:10:15 -0700 2004 -------
The Ant manual says in reference to the <property file="" /> task,

"If the file is not there, nothing is printed except at -verbose log level.
This lets you have optional configuration files for every project, that team
members can customize."

Nevertheless, with the following test file:

<project name="test_input" default="test" basedir=".">
   <taskdef resource="net/sf/ant​contrib/antcontrib.p​roperties" />

   <property file="hoho" />

   <target name="test">
      <property file="haha" />

      <property name="heehee" value="yukyuk" />

      <property file="${heehee}" />

      <if>
        <available file="lala" type="file" />
        <then>
            <property file="lala" />
        </then>
      </if>
   </target>
</project>

We get the following messages, even with 'message level' set to 'warnings.'




Unable to find property file for lala

Unable to find property file for ${heehee}

Unable to find property file for haha

Unable to find property file for hoho

 

 

===== BUILD STARTED =====





BUILD SUCCESSFUL

Total time: 0 seconds

===== BUILD FINISHED =====


It seems to do this *before* the target is called, which might explain the
message Unable to find property file for ${heehee}.

--------------------​--------------------​--------------------​---------
To unsubscribe, e-mail: issues-unsubscribe@a​ntelope.tigris.org
For additional commands, e-mail: issues-help at antelope dot tigris dot org

« Previous message in topic | 1 of 1 | Next message in topic »

Messages

Show all messages in topic

[Issue 21] New - &lt;property file="whatever" /&gt; produces spurious "Unable to find property file" messages esafern Eric Safern 2004-08-02 20:10:18 PDT
Messages per page: