Login | Register
My pages Projects Community openCollabNet

Discussions > issues > [Issue 45] New - Byte Order Mark causes failure to load build file.

antelope
Discussion topic

Hide all messages in topic

All messages in topic

[Issue 45] Byte Order Mark causes failure to load build file.

Author danson
Full name Dale Anson
Date 2009-04-17 16:48:45 PDT
Message http://antelope.tigr​is.org/issues/show_b​ug.cgi?id=45



User danson changed the following:

                What |Old value |New value
====================​====================​====================​====================​
                  Status|NEW |STARTED
--------------------​--------------------​--------------------​--------------------​




------- Additional comments from danson at tigris dot org Fri Apr 17 16:48:45 -0700 2009 -------
I'll look into this, but I don't think I can fix it. Antelope just passes the
file to Ant to parse. It may be possible for me to check for the BOM and strip
it if present before passing it to Ant.

[Issue 45] New - Byte Order Mark causes failure to load build file.

Author volundr
Full name Völundr
Date 2009-04-17 14:13:22 PDT
Message http://antelope.tigr​is.org/issues/show_b​ug.cgi?id=45
                 Issue #|45
                 Summary|Byte Order Mark causes failure to load build file.
               Component|antelope
                 Version|current
                Platform|Sun
              OS/Version|Windows XP
                     URL|
                  Status|NEW
       Status whiteboard|
                Keywords|
              Resolution|
              Issue type|DEFECT
                Priority|P3
            Subcomponent|jEdit Plugin
             Assigned to|danson
             Reported by|volundr






------- Additional comments from volundr at tigris dot org Fri Apr 17 14:13:21 -0700 2009 -------
I'm new to both Ant and Antelope, though I'm a long-time jEdit user.

I'm just getting started playing around with Antelope 3.5.1 / Ant 1.7.1 on
Windows XP SP3.

I created a build.xml file using a Unicode text editor (BabelPad) and when it
saved the file it included the Unicode byte order mark…

http://en.wikipedia.​org/wiki/Byte_Order_​Mark

…which Antelope appears to choke on. (PHP4 and PHP5 do too, so it's no shame.)
 For anyone else running into this problem, BabelPad is able to strip out the
BOM with a check box in its "Save As" dialog.
Messages per page: