Login | Register
My pages Projects Community openCollabNet

Discussions > users > Re: Antelope problems and question

antelope
Discussion topic

Back to topic list

Re: Antelope problems and question

Author Dale Anson <danson at germane-software dot com>
Full name Dale Anson <danson at germane-software dot com>
Date 2005-04-12 09:38:20 PDT
Message Hmm, I'm wondering if it is because you're using Ant 1.5.1. I haven't
used Ant 1.5.x in quite a while, it is possible that something crept in
that is not backwards compatible. Any chance you can upgrade to Ant
1.6.x? In the mean time, I'll get a copy of Ant 1.5 and see what's up.

Dale


Chris Hilton wrote:

>I do still have the problem, though I've discovered it probably has
>little to do with the .ise_prefs directory. I'm able to start 3.2.3 with
>the java command, but I still have the problem of no target buttons
>appearing in run or trace mode for the build file I'm interested in. In
>fact, I went further and tried loading several other build files
>including the run.xml that comes with Antelope 3.2.3 and none of them
>show target buttons. Not sure why that is since none of them show errors
>in the edit mode, but a major problem for me.
>
>Here's where the prefs problem comes in: If I close Antelope with no
>build file loaded, I can restart it just fine. But if I have a build
>file loaded, Antelope dies on startup the next time I run it with the
>following error:
>
>C:\Temp\Antelo​peApp_3.2.3>java -jar AntelopeApp.jar
>ANT_HOME: C:\da_nueces\Produ​cts\Ant\jakarta-an​t-1.5.1
>sourceJar is null so checking Locator
>Antelope.jar URL?
>jar:file:/C:/Tem​p/AntelopeApp_3.2.3/​AntelopeApp.jar!/ise​/antelope/launch
>er/Launcher.class
>JAVA_HOME: C:\j2sdk1.4.2_04\jre
>java.lang.reflec​t.InvocationTargetEx​ception
>
>
> at sun.reflect.NativeMe​thodAccessorImpl.inv​oke0(Native Method)
>
>
> at
>sun.reflect.Nati​veMethodAccessorImpl​.invoke(NativeMethod​AccessorImpl.jav
>a:39)
>
>
> at
>sun.reflect.Dele​gatingMethodAccessor​Impl.invoke(Delegati​ngMethodAccessor
>Impl.java:25)
>
>
> at java.lang.reflect.Me​thod.invoke(Method.j​ava:324)
>
>
> at
>ise.antelope.lau​ncher.SubJarClassLoa​der.invokeMainClass(​SubJarClassLoade
>r.java:251)
>
>
> at ise.antelope.launche​r.Launcher.runApp(La​uncher.java:101)
>
>
> at ise.antelope.launche​r.Launcher.main(Laun​cher.java:65)
>
>
>Caused by: java.lang.NoSuchMethodError:
>ise.antelope.com​mon.AntelopeProjectH​elper2.getImportStac​k()Ljava/util/Ve
>ctor;
>
>
> at
>ise.antelope.com​mon.AntelopeProjectH​elper2.parse(Antelop​eProjectHelper2.
>java:143)
>
>
> at
>org.apache.tools​.ant.ProjectHelper.c​onfigureProject(Proj​ectHelper.java:1
>17)
>
>
> at
>ise.antelope.com​mon.AntelopePanel.cr​eateProject(Antelope​Panel.java:1343)
>
>
> at
>ise.antelope.com​mon.AntelopePanel.op​enBuildFile(Antelope​Panel.java:1025)
>
>
> at
>ise.antelope.com​mon.AntelopePanel.​<init>(AntelopeP​anel.java:388)
>
>
> at
>ise.antelope.com​mon.AntelopePanel.​<init>(AntelopeP​anel.java:176)
>
>
> at ise.antelope.app.Ant​elope.init(Antelope.​java:146)
>
>
> at ise.antelope.app.Ant​elope.<init>(A​ntelope.java:110)
>
>
> at ise.antelope.app.Ant​elope.main(Antelope.​java:968)
>
>
> ... 7 more
>
>
>
>C:\Temp\Antelo​peApp_3.2.3>
>
>The only way I can get rid of this error and start up again is to delete
>the .ise_prefs directory, but I assume it's some bit of startup code
>(perhaps attempting to reload the last build file?) that's the real
>problem.
>
>Chris
>
>-----Original Message-----
>From: Dale Anson [mailto:danson@germa​ne-software.com]
>Sent: Tuesday, 12 April, 2005 10:46
>To: users at antelope dot tigris dot org; Chris Hilton
>Subject: Re: Antelope problems and question
>
>Hi Chris,
>
>I fixed the problem with the preferences directory and posted Antelope
>3.2.3 at antelope.tigris.org. Please let me know if you continue to see
>problems.
>
>I'm not sure if you saw my previous response, to start this version, use
>java -jar AntelopeApp.jar, or (since it looks like you're using Windows)
>you can double click on the jar file. The run.xml file is obsolete.
>
>Thanks,
>
>Dale
>
>Chris Hilton wrote:
>
>
>
>>Unfortunately, I haven't been able to get Antelope to work for me.
>>Antelope 3.2.1 will only run when the .ise_prefs directory does not
>>exist; trying to run it again after a previous run creates that
>>directory results in the following error:
>>
>>C:\Antelope​App_3.2.1>ant -f run.xml
>>Buildfile: run.xml
>>
>>-init:
>>
>>-setClasspath:
>>
>>run:
>> [java] java.lang.NoSuchMethodError:
>>ise.antelope​.common.AntelopeProj​ectHelper2.getImport​Stack()Ljava/util/V
>>e
>>ctor;
>>
>>
>> [java] at
>>ise.antelope​.common.AntelopeProj​ectHelper2.parse(Ant​elopeProjectHelper2
>>
>>
>.
>
>
>>java:143)
>>
>>
>> [java] at
>>org.apache.t​ools.ant.ProjectHelp​er.configureProject(​ProjectHelper.java:
>>1
>>17)
>>
>>
>> [java] at
>>ise.antelope​.common.AntelopePane​l.createProject(Ante​lopePanel.java:1340
>>)
>>
>>
>> [java] at
>>ise.antelope​.common.AntelopePane​l.openBuildFile(Ante​lopePanel.java:1027
>>)
>>
>>
>> [java] at
>>ise.antelope​.common.AntelopePane​l.<init>(Antel​opePanel.java:388)
>>
>>
>> [java] at
>>ise.antelope​.common.AntelopePane​l.<init>(Antel​opePanel.java:176)
>>
>>
>> [java] at ise.antelope.app.Ant​elope.init(Antelope.​java:146)
>>
>>
>> [java] at ise.antelope.app.Ant​elope.<init>(A​ntelope.java:110)
>>
>>
>> [java] at ise.antelope.app.Ant​elope.main(Antelope.​java:968)
>>
>>
>> [java] Exception in thread "main"
>> [java] Java Result: 1
>>
>>BUILD SUCCESSFUL
>>Total time: 3 seconds
>>C:\Antelope​App_3.2.1>
>>
>>When Antelope does run, I load my build file, but the target button
>>area is blank for the run and trace modes. I read this could happen if
>>
>>
>
>
>
>>there's a problem with the build file, but the edit mode shows no
>>problems, nor does any other xml editor and this build file is used to
>>perform dozens of builds a day.
>>
>>I saw that Antelope 3.2.2 is out today, so I downloaded and tried it,
>>but it dies with the following error:
>>
>>C:\Temp\An​telopeApp_3.2.2>j​ava -jar AntelopeApp.jar
>>java.lang.No​ClassDefFoundError: ise/library/FileUtilities
>> at ise.antelope.launche​r.Os.getEnvironmentV​alue(Os.java:317)
>> at ise.antelope.launche​r.AntUtils.getAntHom​e(AntUtils.java:74)
>> at ise.antelope.launche​r.Launcher.init(Laun​cher.java:148)
>> at ise.antelope.launche​r.Launcher.runApp(La​uncher.java:78)
>> at ise.antelope.launche​r.Launcher.main(Laun​cher.java:65)
>>
>>C:\Temp\An​telopeApp_3.2.2>
>>
>>ANT_HOME is set and the ant startup script is in my path.
>>
>>Finally, is there an archive of older Antelope versions? I'd like to
>>try to find one that will work for me.
>>
>>Thanks.
>>
>>Chris Hilton
>>CM Engineer
>>AlterPoint, Inc.
>>
>>
>>
>>
>>
>
>----------------​--------------------​--------------------​-------------
>To unsubscribe, e-mail: users-unsubscribe@an​telope.tigris.org
>For additional commands, e-mail: users-help at antelope dot tigris dot org
>
>
>

--------------------​--------------------​--------------------​---------
To unsubscribe, e-mail: users-unsubscribe@an​telope.tigris.org
For additional commands, e-mail: users-help at antelope dot tigris dot org

« Previous message in topic | 5 of 7 | Next message in topic »

Messages

Show all messages in topic

Antelope problems and question Chris Hilton <chilton at alterpoint dot com> Chris Hilton <chilton at alterpoint dot com> 2005-04-11 08:28:40 PDT
     Re: Antelope problems and question Dale Anson <danson at germane-software dot com> Dale Anson <danson at germane-software dot com> 2005-04-12 08:04:30 PDT
     Re: Antelope problems and question Dale Anson <danson at germane-software dot com> Dale Anson <danson at germane-software dot com> 2005-04-12 08:45:30 PDT
         RE: Antelope problems and question Chris Hilton <chilton at alterpoint dot com> Chris Hilton <chilton at alterpoint dot com> 2005-04-12 09:23:43 PDT
             Re: Antelope problems and question Dale Anson <danson at germane-software dot com> Dale Anson <danson at germane-software dot com> 2005-04-12 09:38:20 PDT
                 RE: Antelope problems and question Chris Hilton <chilton at alterpoint dot com> Chris Hilton <chilton at alterpoint dot com> 2005-04-12 09:54:21 PDT
                     Re: Antelope problems and question Dale Anson <danson at germane-software dot com> Dale Anson <danson at germane-software dot com> 2005-04-14 07:44:22 PDT
Messages per page: