Login | Register
My pages Projects Community openCollabNet

Discussions > users > Re: Error loading tasks

antelope
Discussion topic

Back to topic list

Re: Error loading tasks

Author danson
Full name Dale Anson
Date 2006-08-12 08:50:04 PDT
Message Hi Rob,

I wrote the build file below to check your situation, and it works for
me. I have Ant installed at c:\apache-ant-1.6.5. I created a
subdirectory named "tasks" at c:\apache-ant-1.6.5\tasks and copied
AntelopeTasks_3.2.19.jar into that directory. I put this build file
into c:\temp and named it "test.xml". I opened a cygwin window, changed
to c:\temp and ran "ant -f test.xml". Maybe this will help you
troubleshoot your problem.

Thanks,

Dale


<project name="test" basedir="." default="test">

    <property name="tasks.dir" location="${ant.hom​e}/tasks"/>
    <property name="antelopetasks.jar"
location="${tasks.d​ir}/AntelopeTasks_3.​2.19.jar"/>
   
    <path id="project.classpath">
        <pathelement location="${antelop​etasks.jar}"/>
    </path>
   
    <typedef resource="ise/antelo​pe/tasks/antelope.ta​skdefs"
            classpathref="projec​t.classpath"/>

    <target name="test">
        <assert>
            <bool>
                <not>
                    <datebefore datetime1="2005-09-09 14:58:36"
datetime2="2005-07-11 14:58:36" format="yyyy-MM-dd HH:mm:ss"/>
                </not>
            </bool>
        </assert>
    </target>

</project>

$ ant -f test.xml
Buildfile: test.xml
Trying to override old definition of task length
Trying to override old definition of task replace

test:

BUILD SUCCESSFUL
Total time: 0 seconds


Rob Wilkerson wrote:
> Hey all -
>
> I recently downloaded Antelope Tasks 3.2.19 (what took me so long?)
> and it looks outstanding. Unfortunately, I can't get it to load.
>
> I installed the jar file in %ANT_HOME%/tasks/ so I could keep several
> external libraries together. The jar files for SvnAnt are also loaded
> in that same directory. My build file looks like this:
>
> <!-- path to the svnant libraries -->
> <path id="project.classpath">
> <pathelement location="${svnjavahl.jar}" />
> <pathelement location="${svnant.jar}" />
> <pathelement location="${svnClie​ntAdapter.jar}" />
> <pathelement location="${antelopetasks.jar}" />
> </path>
>
> <!-- load the svn task -->
> <taskdef resource="svntask.properties"
> classpathref="projec​t.classpath"
> />
> <!-- load the antelope tasks -->
> <taskdef resource="ise/antelo​pe/tasks/antelope.ta​skdefs"
> classpathref="projec​t.classpath"
> />
>
> The Subversion tasks load and work just fine, but the Antelope Tasks
> error out as shown:
>
> [taskdef] Could not load definitions from resource
> ise/antelope/tasks/a​ntelope.taskdefs. It could not be found.
>
> I've tried dot notation (as shown in the docs), but the result is the
> same. For the life of me, I can't see the difference. I've unpacked
> the jar file and antelopt.taskdefs does appear to be in that location.
> What am I missing?
>
> Thanks.
>

« Previous message in topic | 2 of 2 | Next message in topic »

Messages

Show all messages in topic

Error loading tasks Rob Wilkerson <r dot d dot wilkerson at gmail dot com> Rob Wilkerson <r dot d dot wilkerson at gmail dot com> 2006-08-11 07:59:10 PDT
     Re: Error loading tasks danson Dale Anson 2006-08-12 08:50:04 PDT
Messages per page: