Login | Register
My pages Projects Community openCollabNet

Discussions > users > Problem with "antcall" targets

antelope
Discussion topic

Hide all messages in topic

All messages in topic

Re: Problem with "antcall" targets

Author Dale Anson <danson at germane-software dot com>
Full name Dale Anson <danson at germane-software dot com>
Date 2004-04-30 08:24:04 PDT
Message I posted Antelope 3.1.5 last night. This should restore the Ant 1.5
compatibility.

Dale


Mary Ellen Foster wrote:
> On Thursday 29 Apr 2004 14:43, Mary Ellen Foster wrote:
>
>>I'm using the following ant version, on Redhat 9:
>> Apache Ant version 1.5.4 compiled on August 13 2003
>
>
> ... and it looks like that was the problem. I just installed Ant 1.6.1
> myself, and it worked fine. Looks like Antelope is using a method that was
> added between 1.5.4 and 1.6.1; is it supposed to be backwards compatible?
>
> MEF
>

--------------------​--------------------​--------------------​---------
To unsubscribe, e-mail: users-unsubscribe@an​telope.tigris.org
For additional commands, e-mail: users-help at antelope dot tigris dot org

Re: Problem with "antcall" targets

Author Dale Anson <danson at germane-software dot com>
Full name Dale Anson <danson at germane-software dot com>
Date 2004-04-29 07:58:44 PDT
Message Hi Mary,

Yes, it is supposed to be backward compatible with Ant 1.5.0 and later.
I dropped the Ant 1.4 compatibility some time ago, but Ant 1.5.4 should
work just fine. I'll look into this, I have to admit to not running Ant
1.5.x in a while...!

Thanks,

Dale



Mary Ellen Foster wrote:
> On Thursday 29 Apr 2004 14:43, Mary Ellen Foster wrote:
>
>>I'm using the following ant version, on Redhat 9:
>> Apache Ant version 1.5.4 compiled on August 13 2003
>
>
> ... and it looks like that was the problem. I just installed Ant 1.6.1
> myself, and it worked fine. Looks like Antelope is using a method that was
> added between 1.5.4 and 1.6.1; is it supposed to be backwards compatible?
>
> MEF
>

--------------------​--------------------​--------------------​---------
To unsubscribe, e-mail: users-unsubscribe@an​telope.tigris.org
For additional commands, e-mail: users-help at antelope dot tigris dot org

Re: Problem with "antcall" targets

Author mef
Full name Mary Ellen Foster
Date 2004-04-29 07:44:27 PDT
Message On Thursday 29 Apr 2004 14:43, Mary Ellen Foster wrote:
> I'm using the following ant version, on Redhat 9:
> Apache Ant version 1.5.4 compiled on August 13 2003

... and it looks like that was the problem. I just installed Ant 1.6.1
myself, and it worked fine. Looks like Antelope is using a method that was
added between 1.5.4 and 1.6.1; is it supposed to be backwards compatible?

MEF

--
__ Mary Ellen Foster __ http://www.iccs.info​rmatics.ed.ac.uk/~me​f/ __
So if someone says: "Let's see The Cat in the Hat"--
Just turn it down flat. I wish I'd done that.
                   Peter Bradshaw, Guardian film review, 2 April 2004

--------------------​--------------------​--------------------​---------
To unsubscribe, e-mail: users-unsubscribe@an​telope.tigris.org
For additional commands, e-mail: users-help at antelope dot tigris dot org

Problem with "antcall" targets

Author mef
Full name Mary Ellen Foster
Date 2004-04-29 06:43:18 PDT
Message I've recently reorganized my build.xml so that my toplevel target does an of other ones, instead of having duplicated stuff all over the place. However, now I can't run those targets with Antelope (3.1.3) -- I get the following backtrace: java.lang.NoSuchMethodError: org.apache.tools.ant.RuntimeConfigurable.getAttributeMap()Ljava/util/Hashtable; at ise.antelope.common.AntProgressListener.doTasks(AntProgressListener.java:276) at ise.antelope.common.AntProgressListener.doCountTasks(AntProgressListener.java:222) at ise.antelope.common.AntProgressListener.countTasks(AntProgressListener.java:209) at ise.antelope.common.AntProgressListener.setExecutingTarget(AntProgressListener.java:151) at ise.antelope.common.AntelopePanel.executeTargets(AntelopePanel.java:699) at ise.antelope.common.AntelopePanel.access$17(AntelopePanel.java:75) at ise.antelope.common.AntelopePanel$13.run(AntelopePanel.java:649) I'm using the following ant version, on Redhat 9: Apache Ant version 1.5.4 compiled on August 13 2003 This happens with standalone Antelope and the jEdit plugin. Here's an excerpt from my build.xml; I can send the whole thing if you want. I can run the "dist-internal" target from Antelope, but if I try to run "install" I get the backtrace I included above. MEF -- __ Mary Ellen Foster __ http://www.iccs.informatics.ed.ac.uk/~mef/ __ So if someone says: "Let's see The Cat in the Hat"-- Just turn it down flat. I wish I'd done that. Peter Bradshaw, Guardian film review, 2 April 2004 --------------------------------------------------------------------- To unsubscribe, e-mail: users-unsubscribe@antelope.tigris.org For additional commands, e-mail: users-help@antelope.tigris.org
Messages per page: